Soundtrack Central The best of VGM and other great soundtracks

Please sign up or log in for the best forum experience!

    Pages: 1

Daniel Feb 5, 2006

Question... Does anyone know if this game requires you to upgrade your firmware to the latest version (2.5 or whatever).  I simply refuse to upgrade my 1.5 firmware because of all the emulation games i have on it!  But I really want this game!!

Jay Feb 5, 2006

I can't say for certain but all of Capcom's recent games (including SFZ3) have required a firmware update so I'd say it probably does.

Related Albums

Tags

Board footer

Forums powered by FluxBB